Degraded functionality in AWS us-east-1

Incident Report for Hightouch

Resolved

Service appears restored, we will continue to monitor.
Posted May 08, 2026 - 01:44 UTC

Monitoring

AWS services appear to be recovering.
Posted May 08, 2026 - 00:39 UTC

Investigating

Customers with workspaces in AWS us-east-1 that use Hightouch Events and RTA products are experiencing degraded functionality due to broad issues in the AWS region. We're monitoring and will restore services as soon as we are able.
Posted May 08, 2026 - 00:30 UTC
This incident affected: Real-time Services (Event ingestion (US), Event syncing (US), Real-time Personalization (US)).