Delayed delivery for a small subset of events

Incident Report for Hightouch

Resolved

The issue is fully resolved. All events are being delivered with normal latencies.
Posted Aug 28, 2025 - 20:05 UTC

Monitoring

We've released a fix and are monitoring to ensure that conditions return to normal.
Posted Aug 28, 2025 - 16:32 UTC

Investigating

We are actively working on mitigating an issue that is causing a small subset of events to be delayed prior to delivery.
Posted Aug 28, 2025 - 14:57 UTC
This incident affected: Events (Event ingestion (US), Event syncing (US)).