Google Sign-On Failures

Incident Report for Hightouch

Resolved

This incident has been resolved. There was no data loss. Impact was limited to Google-authenticated sources and destinations. Syncs that failed during this window will complete successfully on their next scheduled run. No action is required.
Posted Jun 25, 2026 - 15:56 UTC

Monitoring

Google Sign-On has recovered across all regions. We have deployed a fix for the remaining issues affecting some syncs (such as BigQuery) and are continuing to monitor recovery.
Posted Jun 25, 2026 - 15:19 UTC

Investigating

We are currently investigating an issue causing Google Sign-On (SSO) failures. We are actively investigating the issue and will provide an update as soon as more information becomes available.
Posted Jun 25, 2026 - 15:08 UTC
This incident affected: Web Application (Reverse ETL, Customer Studio, Intelligence).