Hightouch app rendering issues

Incident Report for Hightouch

Resolved

This incident has been resolved. Between 8:30 and 10:36 UTC, the app experienced delays and intermittent failures. This has been resolved.

There was no impact to syncs or event delivery.
Posted Aug 13, 2026 - 10:51 UTC

Investigating

We are currently investigating an issue causing delays and errors in the Hightouch UI. We will provide an update as more information becomes available.
Posted Aug 13, 2026 - 10:20 UTC
This incident affected: Web Application (Reverse ETL, Customer Studio, Intelligence).