Slow Application Loading and Intermittent UI Errors

Incident Report for Hightouch

Monitoring

The Hightouch application is now stable. We are continuing to monitor and we will provide updates as the situation evolves.
Posted Sep 21, 2026 - 21:42 UTC

Update

We are continuing to investigate this issue.
Posted Sep 21, 2026 - 21:25 UTC

Investigating

We’re investigating an issue causing slow application loading and intermittent errors in the UI. We’re working to resolve it and will share another update shortly.
Posted Sep 21, 2026 - 20:48 UTC
This incident affects: Web Application (Reverse ETL, Customer Studio, Intelligence).