Resolved - Elevated 404 Responses on API Endpoints

Incident Report for Hightouch

Resolved

Between 10:38am and 12:34pm PDT, we observed an increase in 404 responses for API requests. The issue has been identified and resolved. All API services have returned to normal operation. We apologize for the disruption and appreciate your patience.
Posted May 20, 2025 - 20:05 UTC
This incident affected: REST APIs (Customer API).