Completed
The scheduled maintenance has been completed.
Posted Sep 24, 2025 - 01:57 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 24, 2025 - 00:45 UTC
Scheduled
We will be performing scheduled maintenance on Tuesday, September 23, 2025, from 5:45 to 6:30 PM PST.
During this time:
• The Hightouch web application and APIs will be temporarily unavailable
• The ability to trigger a sync run via API or Extension will be impacted
• All active syncs will be paused and will resume once maintenance is complete
We understand that every second of availability matters, and we appreciate your trust and patience as we work to improve our platform.
Posted Sep 05, 2025 - 16:31 UTC
This scheduled maintenance affected: Sync Engine (AWS ap-south-1 (Mumbai), AWS eu-west-1 (Ireland), AWS us-east-1 (N. Virginia), GCP us-east4 (N. Virginia), GCP europe-west1 (Belgium), Azure eastus (Virginia)), Web Application (Reverse ETL, Customer Studio, Intelligence), Integrations (Sources, Destinations), REST APIs (Customer API, Partner API), Personalization API (AWS eu-west-1 (Ireland), AWS us-east-1 (N. Virginia), AWS us-west-2 (Oregon)), Extensions (Alerting, Datadog, dbt, Fivetran, Git, Looker, Sigma), Events (Event ingestion (US), Event syncing (US), Event ingestion (EU), Event syncing (EU)), and AI Decisioning, Identity Resolution, Match Booster.