App Errors

Incident Report for Hightouch

Resolved

This incident has been resolved. Between 18:12 and 18:27 UTC, the Hightouch app experienced intermittent login and application errors. There was no impact to event delivery or syncs.
Posted Aug 19, 2026 - 19:50 UTC

Investigating

We are investigating intermittent login and application errors affecting the Hightouch app. We will provide an update as more information becomes available.
Posted Aug 19, 2026 - 18:37 UTC
This incident affected: Web Application (Reverse ETL, Customer Studio, Intelligence).